The 2014 Corvette Stingray Forum
News / Blog Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read

Go Back   Chevrolet Corvette Stingray C7 Forum > Technical Forums > Wheels | Tires | Suspension | Brakes

Reply
 
Thread Tools
Old 06-01-2017, 02:08 PM   #1
PR325xi
 
Drives: 2013 2LT RS
Join Date: Mar 2013
Location: anywhere
Posts: 171
Suspension problem?

Hello all,

I have a little problem with my rear right shock? Or that's what I'm trying to figure out. Couple months ago I noticed that my rear right wheel was hoping up and down whenever I went on tough roads or went over some uneven roads, much like when your shocks go bad, so I decided to buy some blistein shocks for the rear, so I installed them and noticed the same but less, so I let it be for the moment. Fast forward 1 month and my car was leaking from the differential so I took it to the dealer to have it checked, they replaced the gasket and seals on warranty and told me that the rear right blistein shock was leaking, "no big deal" I thought, "that's why it was still jumping" so I went and got the shock replaced on warranty by autozone and installed the new shock and guess what? It still jumps! So I don't know what could it be, the car drives good except for that jumpy wheel, the shock is not leaking, seems fine, links and bushings are good and tight, the tires are Pirelli pzero and with 1 year on em and are on good shape, what else could it be?

Car has 58k miles


Sent from my iPhone using Tapatalk
PR325xi is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:33 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.