The 2014 Corvette Stingray Forum
News / Blog Register Members List Social Groups Calendar Search Today's Posts Mark Forums Read

Go Back   Chevrolet Corvette Stingray C7 Forum > Technical Forums > LT1 (6.2L V8) Powertrain and Drivetrain Discussions

Reply
 
Thread Tools
Old 11-04-2017, 07:07 PM   #1
maringreg
 
Drives: 2015 C7 Corvette Coupe 7 speed
Join Date: Feb 2015
Location: California
Posts: 1
Question 2015 Z51 Camshaft damaged

after hearing a distinct clicking noise, I brought our 2015 Z51 7speed Stingray into the dealer to see if maybe an exhaust leak, fuel injector or something electronic was making the noise. It was clear to everyone including the person at check in. The Chevrolet Dealership here in Novato, CA told me that their tech thought it was a lifter, then after a few days called to tell me it was a camshaft that was causing the problem and that it would take "several weeks" to repair.

If it's a camshaft, wouldn't it be an oiling issue or maybe a problem with manufacturing??? And if so, then wouldn't it make sense to replace the motor vs hoping that it won't happen again? Isn't a "few weeks" quite a long time to fix it? We could build a whole house in that time.

Please provide your inputs and let me know if anyone else has experienced this problem.


Last edited by maringreg; 11-19-2017 at 09:53 PM.
maringreg is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:53 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.